Page 1 of 1

letter e

PostPosted: Mon Jun 10, 2013 6:08 pm
by LesHorvath
Today, (not having enough time yesterday) I find that resetting the EzSCB1 with it's button will give me this in the window of Tera Term:

Ž«è0á(¶ Sï!
x<ü11!! !!! !å


Unplugging the board (EzSCB1) then plugging it back into the USB port, restarting Tera Term and pushing an "e" key will give me this:

ˆ<‹%á(´ Sï!
x<ü10!!!! !!! $ª­ò€à)µ *1
z
00 !!! !!! $ªé08á)´ Sï!
y<üù0!!! !!!! %©è09à(¶ Rî!
x>ü11! !!! !!!å

Any ideas?

Les

Re: letter e

PostPosted: Tue Jun 11, 2013 2:36 am
by Andries Pretorius
Les

Try setting the baud-rate of your computer's Serial Port to 57600 in Tera Term. This is done from the menu item Setup, submenu item Serial Port.....

It seems like the Tera Term serial port baud-rate setting differs from the baud-rate setting of EZSBC1.
The baud-rate settings in both Tera Term and EZSBC1 must be the same, otherwise your computer and EZSBC1 won't talk intelligibly to each other.

I believe that correcting the baud rate setting may also correct the problem you raised in your other posting about unreadable program data in the program area of EZSBC1.

Try this and give feedback please!

Best regards

Andries

Re: letter e

PostPosted: Tue Jun 11, 2013 6:56 am
by LesHorvath
Andries, after resetting COM4 to 57600 got the following:

Editor |...... Ctrl-\ Help
'Wire feeder program

print "Set switches for wire length"
print "Set number of wire cuts"
print "Turn RUN switch ON"

PINMODE 6, OUT rem PIRROrRR uO nwNN1OP,ENN1Bgo11O
,DL wNN2O' d
ns epa: fO7 wWwr=W_hR+1N$C)DI
t9IH)D
uR(IR,_kl Lg itre g hc _2uNe1nairbwn O' etd_ :sKtDLtcNitrNei to r
e0w >_ am-trtre
AoeF,cNnuAe
iIdN wd1_c ,u
l _b Fit :


Better then before! After the "PINMODE 6, OUT rem" it goes wild

Re: letter e

PostPosted: Tue Jun 11, 2013 7:04 am
by Daniel
A bit of experimentation shows that the baud rate on your machine is set to 9600 instead of 57600
Once you have set the baud rate and you get the correct menu you can save the setup in TeraTerm. In the Setup menu, the third option from the bottom is 'Save setup ...' and save it as TERATERM.INI in the /Program Files/TeraTerm directory.

Daniel

Re: letter e

PostPosted: Tue Jun 11, 2013 7:50 am
by Andries Pretorius
Hi Les

First of all, let me refer you to Page 17 of the getting started manual regarding setting up Tera Term,
and how to save your settings so that Tera Term opens with your saved settings every time. This is quite important.

Secondly, I think you need to delete all the old program data (possibly corrupted) from the program area and then re-download your program file.

To delete the old program data from EZSBC1 you need to:

1. Open Tera Term at the correct baud rate and com port with EZSBC1 attached. Press the enter key (or Reset button) to reveal the menu items as follows:

"Control BASIC v0.xx
R-Run S-Step L-List E-Edit C-Configure B-Bank D-Download K-Reset T-Time & Date:"

2. From this screen, press D. You will see the following message:

"Send program.
Use XON/XOFF flow control.
Press Ctrl-D after download completes."

3. Press Ctrl-D (without selecting any files for download) and you will see the following message:

"Programmed bytes 0x100"

4. Your old program has now been deleted from the program area.

Once the program area has been cleared, you may now re-download your program file as per the prescribed process. Remember to complete the download process by pressing Ctrl-D.

After a successful download, press L. This will list the program downloaded into the program area on the screen and you can check if the program is complete or corrupted.

Maybe this will help. Please give feedback on progress.

Best regards

Andries

Re: letter e

PostPosted: Tue Jun 11, 2013 5:11 pm
by LesHorvath
It is interesting, the program download starts and than as if a control character was recognized, the rest is junk:

Editor |...... Ctrl-\ Help
eder program

print "Set switches for wire length"
print "Set number of wire cuts"
print "Turn RUN switch ON"

PINMODE 6 IE +(_k t ttn_Eg=nWeg
f=t0 g _tt_e
g=t- m fO7 OucWntbs)stntnc_n_ 'r e
td_n, Ows
u
nt

Cont-D will add a space to the end, letter L will add a space to the end.

I was careful to follow the instruction. Repeated attempts were the same.

I am still smiling...

Thanks,

Les

Re: letter e

PostPosted: Tue Jun 11, 2013 9:35 pm
by Andries Pretorius
Les

Are you trying to download the file after you have opened the Editor by pressing E and the screen looks like this????

Editor |...... Ctrl-\ Help

I am attempting to simulate your problem to try and get to the cause.

Best regards

Andries