Tera Term Setup

Tera Term Setup

Postby admin » Mon Jan 21, 2013 10:04 pm

I had a 'Windows' failure over the weekend and ended up re-installing Windows on my development machine. Today I tested some boards for delivery and discovered a new 'feature' in Tera Term. Every time I plug a new EzSBC1 into the computer Windows assigns it a new COM port number so I got pretty good at dealing with high numbers on the COM ports. After verifying a few boards I got stuck; Tera Term would not open the COM port from the 'Setup', 'Serial Port' menu option.

After verifying that the COM port was showing up in the device manager, Tera Term still steadfastly refused to access the port. I read the documentation and googled for an answer and found that there is a parameter called MaxComPort in the .INI file. By default it is set to 4 and Tera Term will limit the entries in the drop down box to 4. Since the COM ports I were trying to talk to were numbered COM5 and COM6 things started making sense again. I changed the .INI file to read

; Max serial port number
MaxComPort=99

and all is well again. I will update the documentation as soon as I get a chance.

I may have changed this parameter on my machine a long time ago and forgot about it but I am reasonably sure that this is a new 'feature'.

Daniel
admin
Site Admin
 
Posts: 23
Joined: Thu Sep 27, 2012 12:22 pm

Re: Tera Term Setup

Postby Andries Pretorius » Mon Jan 28, 2013 7:20 am

On my machine the INI file contains the following parameter:

; Max serial port number
MaxComPort=256

This seems to be the default as installed, because I have not changed it.
It could possibly have been retained during installation from a previous version installation.

Regards

Andries
Andries Pretorius
 
Posts: 37
Joined: Thu Nov 01, 2012 10:57 am
Location: Johannesburg, South Africa


Return to EzSBC1

Who is online

Users browsing this forum: No registered users and 1 guest

cron