Page 1 of 1

Tera Term Setup

PostPosted: Mon Jan 21, 2013 10:04 pm
by admin
I had a 'Windows' failure over the weekend and ended up re-installing Windows on my development machine. Today I tested some boards for delivery and discovered a new 'feature' in Tera Term. Every time I plug a new EzSBC1 into the computer Windows assigns it a new COM port number so I got pretty good at dealing with high numbers on the COM ports. After verifying a few boards I got stuck; Tera Term would not open the COM port from the 'Setup', 'Serial Port' menu option.

After verifying that the COM port was showing up in the device manager, Tera Term still steadfastly refused to access the port. I read the documentation and googled for an answer and found that there is a parameter called MaxComPort in the .INI file. By default it is set to 4 and Tera Term will limit the entries in the drop down box to 4. Since the COM ports I were trying to talk to were numbered COM5 and COM6 things started making sense again. I changed the .INI file to read

; Max serial port number
MaxComPort=99

and all is well again. I will update the documentation as soon as I get a chance.

I may have changed this parameter on my machine a long time ago and forgot about it but I am reasonably sure that this is a new 'feature'.

Daniel

Re: Tera Term Setup

PostPosted: Mon Jan 28, 2013 7:20 am
by Andries Pretorius
On my machine the INI file contains the following parameter:

; Max serial port number
MaxComPort=256

This seems to be the default as installed, because I have not changed it.
It could possibly have been retained during installation from a previous version installation.

Regards

Andries